InfoSec Forums InfoSec Forums Wireless Penetration Testing Framework for Rogue Wi-Fi Access Point Attack – WiFi-Pumpkin

This topic contains 6 replies, has 2 voices, and was last updated by do son do son 3 weeks, 5 days ago.

  • Author
    Posts
  • #3974
    do son
    do son
    Moderator
    • Topics:194
    • Comments:47
    • Super Member
    • ★★★★

    WiFi-Pumpkin is an open source security tool that provides the Rogue access point to Man-In-The-Middle and network attacks.
    WiFi-Pumpkin v0.8.3


     

    • added new design main tool
    • added new column VendorMac in man Table
    • added set sorted in all Tablewidget
    • added new plugins options and description
    • added more options in statusbar main
    • fixed allow traffic to/from wlan (iptables)
    • added find file in directory cfg for check update
    • changed the all directory structure characters to lowercase
    • ffixed No such file or directory [logs] #102
    • fixed Error nmcli exceptions.OSError #104
    • added error messages more explained
    • added option to set Hostapd binary path (support hostapd-mana)
    • fixed improvements fuctions get_interfaces #109
    • added new plugin Responder (LLMNR, NBT-NS and MDNS poisoners)
    • fixed Redirect traffic from all domains in dnsspoof module
    • removed isc-dhcp-server(dhcpd) from dedependencies (optinal)
    • added check if interface wireless support AP/Mode
    • added python implements a DHCP Server by psychomario
    • fixed installer:install mitmproxy in ubuntu
    • added function: get possible errors from hostapd service
    • fixed get_file_cfg_Update: get update from github
    • fixed DNSServer: closes itself with this error #116
    • fixed report.py: check if module QtWebKit is installed #120

    Download:

    https://github.com/P0cL4bs/WiFi-Pumpkin/archive/v0.8.3.zip

    Installing:

    cd WiFiPumpkin
    chmod +x installer.sh
    ./installer.sh install
    Update
    cd WiFiPumpkin
    git pull origin master

    No system is truly secure!

  • #3984

    cyber ghost
    Participant
    • Topics:1
    • Comments:11
    • Newbie

    Sir their is an error that wlan0 not supported

    Help,……

  • #3988
    do son
    do son
    Moderator
    • Topics:194
    • Comments:47
    • Super Member
    • ★★★★

    @cyber ghost this tool require two wireless card.

    No system is truly secure!

  • #3989

    cyber ghost
    Participant
    • Topics:1
    • Comments:11
    • Newbie

    I have my lan system and also WiFi card than it will done or not

    • #3997
      do son
      do son
      Moderator
      • Topics:194
      • Comments:47
      • Super Member
      • ★★★★

      tw0 wireless card….

      No system is truly secure!

  • #3998

    cyber ghost
    Participant
    • Topics:1
    • Comments:11
    • Newbie

    Ok sir and thanku for help…

  • #4455
    do son
    do son
    Moderator
    • Topics:194
    • Comments:47
    • Super Member
    • ★★★★

    Wifi-Pumpkin v0.8.4 released.

    Change log:

    Version 0.8.4
    ————-
    – added new plugin Pumpkin-Proxy (mitmproxy API)
    – added new notifications for donations
    – fixed theme default QtableView Color hover

    Installing
    git clone https://github.com/P0cL4bs/WiFi-Pumpkin.git
    cd WiFi-Pumpkin
    chmod +x installer.sh
    ./installer.sh –install

    Update
    cd WiFi-Pumpkin
    git pull origin master

    then run
    wifipumpkin (ubuntu)
    wifi-pumpkin (kali 2.0)

    Debian/Ubuntu Binary;
    wget https://github.com/P0cL4bs/WiFi-Pumpkin/releases/download/v0.8.4/wifi-pumpkin-0.8.4-all.deb
    sudo dpkg -i wifi-pumpkin-0.8.4-all.deb

    No system is truly secure!

You must be logged in to reply to this topic.